Intermittent Twitter Login Issues (external incident)
Incident Report for Skedda
Resolved
Twitter has published a status post about the incident here: https://api.twitterstat.us/

At the time of writing, we're seeing recovery, and Twitter logins are now working as expected. Closing this as resolved.
Posted Feb 26, 2021 - 13:38 UTC
Update
Twitter is continuing to respond with "Service Unavailable" errors for the relevant OAuth endpoint and we are still monitoring and waiting for Twitter's resolution.
Posted Feb 26, 2021 - 12:16 UTC
Monitoring
For approximately the last 15 minutes, we've noticed that some attempts to log in to Skedda via a Twitter account are showing errors to the user. The underlying cause is that the authentication endpoints on Twitter's side that are required to complete the log-in flow are returning a 503 "Service Temporarily Unavailable" error to Skedda. That is, it's an external incident that we aren't able to resolve from our side and we must wait for Twitter to resolve the issue on their side.

Only logins via Twitter are affected.

Affected users can request a login-reset email from our login page (https://app.skedda.com/account/login) and set up a different authentication method (password, Google, Facebook or Microsoft login) to get in to their Skedda account if they're blocked by this Twitter issue.

We expect Twitter to resolve this issue soon and will provide updates here within 60 minutes or as events warrant.
Posted Feb 26, 2021 - 11:55 UTC
This incident affected: User Portal.