New-account sign-up currently not possible from Skedda's marketing pages (www.skedda.com)
Incident Report for Skedda
Resolved
This issue is now resolved (the sign-up form is displaying correctly again on our marketing pages, www.skedda.com).
Posted Jun 09, 2022 - 08:18 UTC
Identified
Skedda's marketing pages (www.skedda.com) are currently not showing the sign-up form for creating a new account. We have identified the root cause and are working to resolve it. We will provide an update within 60 minutes or as events warrant.
Posted Jun 09, 2022 - 08:13 UTC