Degraded email message delivery
Incident Report for Skedda
Resolved
We are now resolving this incident from our side as we've seen no further issues for 60 minutes. We expect our email service provider to mark it as resolved on their side soon as well. We will re-open the incident in the unlikely event that the situation regresses.

We apologize for any inconvenience caused by delayed email messages and thank you for your understanding.
Posted Feb 21, 2022 - 20:04 UTC
Update
Our email service provider has implemented a fix for the issue and we are observing recovery. Messages may however still be delayed by some minutes considering the retry interval on Skedda's side and the backlog of messages on the email provider's side that built up during the incident. We will provide another update when the email service provider has marked the incident as resolved.
Posted Feb 21, 2022 - 19:26 UTC
Update
Our email service provider continues to investigate this incident, which is causing delayed delivery of Skedda transactional emails. We continue to monitor their progress and will provide an update within 60 minutes or as events warrant.
Posted Feb 21, 2022 - 19:14 UTC
Monitoring
The cause of the issue lies at our email service provider's end, where it's currently being investigated. See here for more details:

https://status.mailgun.com/

Skedda retries sending messages automatically and periodically, so Skedda users can still expect to receive all messages, however with some delay as a result of this incident.

We will continue to monitor the resolution of this incident on the side of our provider and provide an update here within 60 minutes or as events warrant.
Posted Feb 21, 2022 - 18:42 UTC
Investigating
Skedda engineers are currently investigating an alert related to the delivery of email messages. We will provide an update within 30 minutes or as events warrant.
Posted Feb 21, 2022 - 18:37 UTC
This incident affected: Email Delivery.