Slightly Elevated Web App Errors
Incident Report for Skedda
Resolved
This incident is now resolved and Skedda is fully operational.
Posted Dec 14, 2021 - 10:50 UTC
Update
We are continuing to investigate this minor incident together with our hosting provider. The incident is currently affecting *less than 1%* of all requests to our services. See the other comments in this incident for information about the scope. We will provide another update within 4 hours or as events warrant.
Posted Dec 14, 2021 - 09:51 UTC
Update
We are continuing to investigate this issue. So far, the errors are occurring on only approximately 1% of requests sent to our services, so the impact of this incident is low and retries should normally succeed. Based on an analysis of the "user agent strings" that are associated with the failing requests, it is apparent that the errors are mainly isolated to non-browser agents like external calendar agents (Google Calendar, Apple Calendar, Outlook etc). This means that most users accessing Skedda on a browser will likely not experience any problems.

We will provide another update within 2 hours or as events warrant as we continue to investigate this.
Posted Dec 14, 2021 - 08:40 UTC
Update
The errors are largely associated with requests coming from non-browser user agents like external calendars (e.g. iCal requests coming from Google Calendar, Outlook, Apple Calendar on iPhone etc). If you are seeing errors when syncing external calendars with Skedda, this is likely the reason. As a temporary workaround, you can view bookings within Skedda (rather than your external calendar) for the time being. We will provide another update in 60 minutes or as events warrant as we continue to investigate this.
Posted Dec 14, 2021 - 07:54 UTC
Investigating
We're currently seeing a slightly elevated level of errors coming from our web application. The vast majority of requests to our services are succeeding as usual, but users may see the odd request fail with a "503 Service Unavailable" error or similar. Retrying requests will often succeed. We will provide another update in 60 minutes or as events warrant as we investigate this.
Posted Dec 14, 2021 - 07:23 UTC
This incident affected: Admin Dashboard and User Portal.