Cloudflare has resolved the underlying incident and we have seen no further issues from our side.
Posted Nov 18, 2025 - 20:06 UTC
Update
Cloudflare has confirmed that a fix has been implemented, and we can confirm what appears to be full recovery from our side. We will continue to monitor and resolve this incident once Cloudflare has closed the underlying incident.
The Cloudflare team is currently working on resolving the incident and we will provide an update within 30 minutes or as events warrant.
Skedda customers may continue to see errors on Skedda accounts while the third-party incident is being resolved, and we thank you for your patience.
Posted Nov 18, 2025 - 11:51 UTC
Investigating
We're currently seeing an elevated level of errors coming from our web application. We're looking into the issue as a matter of priority. If you are unable to access your Skedda account, this incident is likely the reason and we thank you for your patience as we work through it. We will provide another update in 60 minutes or as events warrant.
Posted Nov 18, 2025 - 11:41 UTC
This incident affected: Admin Dashboard and User Portal.